NXT et rubik's cube

Présentez-nous vos créations...
efjie2002
Level 10
Level 10
 
Messages: 1708
Localisation: Bar Sur Seine, Aube, champagne-Ardennes
Âge: 45 ans
collectionneur

Messagepar efjie2002 » Ven Fév 20, 2009 8:08 pm

sur les conseils d'Anio, j'ouvre ce topic, suite de celui-ci

détails, notice, vidéo, programme

Image

je me suis plus que penché sur le sujet en apportant quelques modifications au modèle lui même (pour faciliter la rotation du cube) et je bute désespérément sur un problème qui empêche le fonctionnement correct du programme qui, même pour un cube "résolu", propose au minimum 32 mouvements.
D'où cela peut-il bien venir ? De la calibration ? j'ai testé plusieurs position du bras du capteur: sans succès....

Si d'autres curieux ont tentés de monter ce MOC avec plus de sucres que moi, je suis preneur du récit de vos expériences.

Avatar de l’utilisateur
kiko100
Level 2
Level 2
 
Messages: 17
Localisation: Paris

Messagepar kiko100 » Ven Fév 20, 2009 9:23 pm

Petite question (en m'excusant par avance si elle est trop idiote) : As-tu bien lancé le programme "cubetester" sur un cube résolu pour qu'il teste si ton jeu de couleur lui plait ? Normalement, il affiche pour chacun des 9 carrés de chaque face le n° correspondant à la couleur scanné (je dis n° mais ça doit être l'intensité ou un truc du genre). Et à la fin, il te dit si ton cube est bon pour lui.
C'est juste pour qu'il teste si les 9 carré de chaque face sont bien dans une même fourchette, et si les 6 fourchettes de chaque face sont bien disjointes.
C'est grâce à ça que j'avais étalonné mes couleurs (voir la page http://tiltedtwister.com/instructions.html). Et après, quand je lui faisais résoudre un cube "résolu", il n'y avait pas de problème : 0 mouvement. Donc s'il t'en propose 32, c'est que tes couleurs ne vont pas.
Une dernière chose : le mettre bien à la lumière me semblait assez efficace.
Une après-dernière chose (!) : si tu peux me dire les modifs que tu as apportées pour faciliter la rotation, je suis preneur.

Avatar de l’utilisateur
Alban42800
Level 11
Level 11
 
Messages: 2473
Localisation: Loire (42)
Âge: 47 ans
expertgbbexpertnxtvainqueurconcours

Messagepar Alban42800 » Ven Fév 20, 2009 10:25 pm

J'ai pas cette expérience mais si tu as un problème de lecture :
- essayer avec différents éclairages (néon, lampe à incandescence, ...) mais pas la lumière du jour qui est variable.
- Attention à l'espace entre le capteur et le cube qui doit être constante.

Darth Bug
Level 4
Level 4
 
Messages: 55

Messagepar Darth Bug » Sam Fév 21, 2009 7:25 am

:) Bon bah j'ai posté ailleurs mais je reposte ici
Pour un emeilleure rotation, pensez à nettoyer son cube...pas les faces hein! L'intérieur, je dis bien :D et à le lubrifier avec de l'huile de silicone, pour le démonter faire tourner une face de 45° et soulever une arête. Attention pour le remonter, pensez à le remonter en position finie car en remettant les cubes au hasard, vous risquez de tomber sur une mauvaise surprise...un cube insolvable :pamafote:

efjie2002
Level 10
Level 10
 
Messages: 1708
Localisation: Bar Sur Seine, Aube, champagne-Ardennes
Âge: 45 ans
collectionneur

Messagepar efjie2002 » Sam Fév 21, 2009 12:39 pm

hum, en gros on m'a trompé à l'insu de mon plein gré en m'offrantun faux rubik's il y a 20 ans: je vais traquer les coupables ! et commencer par rechercher un "vrai".

Pour ce qui est du test de cube: je n'en n'ai pas à effectuer avec un color sensor mais en vérifiant par acquis de consciences les données brute du sensor par un programme test, je me suis aperçu ce matin que plusieurs faces donnaient la même "réponse".
la traque continue...

Avatar de l’utilisateur
kiko100
Level 2
Level 2
 
Messages: 17
Localisation: Paris

Messagepar kiko100 » Sam Fév 21, 2009 3:50 pm

Si le color sensor donne de moins bons résultats que le light sensor, où va le monde ?!

efjie2002
Level 10
Level 10
 
Messages: 1708
Localisation: Bar Sur Seine, Aube, champagne-Ardennes
Âge: 45 ans
collectionneur

Messagepar efjie2002 » Sam Fév 21, 2009 4:08 pm

kiko100 a écrit:Si le color sensor donne de moins bons résultats que le light sensor, où va le monde ?!


ben ecoute, je me pose des questions: il est livré avec un nuancier de correspondance couleur-chiffre et le bleu et le vert ne donnent rien....

Darth Bug
Level 4
Level 4
 
Messages: 55

Messagepar Darth Bug » Sam Fév 21, 2009 10:20 pm

Sur son site il est conseillé si tu ne veux pas changer les sticker d'utiliser un color sensor mais il faut éviter la lumière directe vers le cube (j'imagine que ça doit faire des reflets qui gêne la reconaissance des couleurs) :think:
En ce qui concerne ton cube d'il y'a 20 ans, il se pourrait que ce soit un vrai quand même...un petit nettoyage me parait indispensable si ça n'a jamais été fait ;) tu verras que la différence est ENORME entre un cube propre et un cube tout poussiereux!

efjie2002
Level 10
Level 10
 
Messages: 1708
Localisation: Bar Sur Seine, Aube, champagne-Ardennes
Âge: 45 ans
collectionneur

Messagepar efjie2002 » Sam Fév 21, 2009 11:12 pm

au diable l'avarice: j'ai acheté un nouveau rubik's et il est vrai que les couleurs ont changées: j'essaierais cela dans une semaine après mes vacances: a Bientôt !

Darth Bug
Level 4
Level 4
 
Messages: 55

Messagepar Darth Bug » Jeu Fév 26, 2009 9:59 pm

Bah alors comment ça avance pas les travaux?

efjie2002
Level 10
Level 10
 
Messages: 1708
Localisation: Bar Sur Seine, Aube, champagne-Ardennes
Âge: 45 ans
collectionneur

Messagepar efjie2002 » Dim Mar 01, 2009 11:09 pm

pfff, même avec un rubik tout neuf avec des couleurs plus "vives", ça foire: mais qu'est ce que je rate ?
ça me démoralise.

une question: lors du calibrage: où placer le capteur ?

efjie2002
Level 10
Level 10
 
Messages: 1708
Localisation: Bar Sur Seine, Aube, champagne-Ardennes
Âge: 45 ans
collectionneur

Messagepar efjie2002 » Lun Mar 02, 2009 12:06 pm

derniers essais: Pour un cube "en ordre"
soit le nxt continue a me proposer une quarantaine de mvts
soit il bugge et ne donne aucune réponse (son de plus en plus aigu ss solution)

Avatar de l’utilisateur
Nico71
Level 14
Level 14
 
Messages: 9609
Âge: 31 ans
expertgbbexpertsoft3dexperttrialtruckmoceurtechnicexpertvainqueurconcours3

Messagepar Nico71 » Lun Mar 02, 2009 1:26 pm

atta efgie, ok ton robot marche mal mais montre nous ! fais une vidéo qu'on voit si c'est mécanique ou si c'est le prog. si c'est le prog est que c'est le même, le cube est le seul elements exterieur.

efjie2002
Level 10
Level 10
 
Messages: 1708
Localisation: Bar Sur Seine, Aube, champagne-Ardennes
Âge: 45 ans
collectionneur

Messagepar efjie2002 » Lun Mar 02, 2009 4:52 pm

Nico71 a écrit:atta efgie, ok ton robot marche mal mais montre nous ! fais une vidéo qu'on voit si c'est mécanique ou si c'est le prog. si c'est le prog est que c'est le même, le cube est le seul elements exterieur.


bon je suis un boulet ok. donc j'ai tout démonté et remonté strictement en conformité avec le modèle. J'utilise un capteur de couleur hitechnics et un rubik's tous les deux flambants neufs: résultat= toujours le même c'ad au minimum une solution à 20 mvts pour un cube ordonné !!!.
J'effectue la calibration ss prb si ce n'est le retour du bras de capteur un peu "mou"...

ps: pas de poss de faire une vidéo dsl

Avatar de l’utilisateur
Alban42800
Level 11
Level 11
 
Messages: 2473
Localisation: Loire (42)
Âge: 47 ans
expertgbbexpertnxtvainqueurconcours

Messagepar Alban42800 » Lun Mar 02, 2009 6:00 pm

A ce que tu dis c'est clairement le programme qui déconne.
Si le test de lecture des couleurs fonctionne et que le programme de résolution utilise les mêmes positions du capteur pour la lecture... donc il arrive à lire correctement le cube.
Il le tourne dans tous les sens pour connaître chaque face.
Il calcule la solution et trouve trop de mouvements...

Au fait, tu l'a laissé faire ses 20 mvts avec un cube ordonné ? quel est le résultat (cube mélangé) ?

T'a essayé de voir dans les forums anglophones comme nxtasy si le sujet était traité ?


Retourner vers Vos MOCs Technic

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : Aucun utilisateur inscrit et 8 invités