SBrick

Besoin d'informations sur une pièce précise ?
Avatar de l’utilisateur
YodaSoftware
Level 8
Level 8
 
Messages: 937
Localisation: POITIERS (86)
Âge: 50 ans
collectionneur

Messagepar YodaSoftware » Sam Déc 27, 2014 5:30 pm

tu peux essayer de te connecter au play store sur ton PC avec le compte associé à ton tél, et ajouter l'appli : https://play.google.com/store/search?q=sbrick&hl=fr
elle s'installera automatiquement sur le tél.
Ma Collection BrickSet
Mes « I want » BrickSet

May Charlie be with us . . . Always !

Avatar de l’utilisateur
YodaSoftware
Level 8
Level 8
 
Messages: 937
Localisation: POITIERS (86)
Âge: 50 ans
collectionneur

Messagepar YodaSoftware » Sam Déc 27, 2014 5:32 pm

oracid a écrit:Oui mais quand tu fais la recherche, vois-tu l'application sbrick dans la liste ?

elle est installée, c'est lors de la recherche de la SBrick que ça mouline dans le vide (il demande l'activation du bluetooth dès l'ouverture de l'appli s'il ne l'est déjà)
Ma Collection BrickSet
Mes « I want » BrickSet

May Charlie be with us . . . Always !

Avatar de l’utilisateur
shreckbull
Level 5
Level 5
 
Messages: 133
Localisation: Dijon
Âge: 33 ans

Messagepar shreckbull » Sam Déc 27, 2014 5:35 pm

Pour le sony xperia sp, il supporte le bluetooth 4.0. Mais la brique utilise un mode bien particulier : le low energy. Pour supporter ce mode, il faut que la puce bluetooth fonctionne avec un nouveau protocole, peut etre que le firmware sony ne l'inclus pas..
Il peut aussi s'agir d'un problème de l'application. Elle présente encore quelques bugs. Je n'ai pour le moment réussi à faire fonctionner qu'une seule brique sur deux.


Concernant la version d'android, oui une 2 alias gingerbread ou une 3 honeycomb, le problème est réglé: non supporté.

Je vais regarder dans les SDK android que j'ai, mais je crois que c'est à partir du 4.2.2 que le bluetooth LE est supporté. Il faut deux choses, le support par le framework android et un support coté firmware puces bluetooth.



Une solution pour ceux ayant des smartphones anciens, est de trouver une ROM alternative telle que cyanogenmod ou d'autres sur la communauté XDA, certains ont peut etre rajouté ce support du BLE. C'est ce que je suis en train de regarder pour ma tablette.

Avatar de l’utilisateur
ramoutcho_7387
Level 11
Level 11
 
Messages: 2594
Localisation: France, Franche-Comté, Doubs, Besançon, 25000
Âge: 33 ans
collectionneur

Messagepar ramoutcho_7387 » Sam Déc 27, 2014 5:40 pm

oracid a écrit:
ramoutcho_7387 a écrit:Moi, j'ai un Samsung Galaxy Note GT-N7000 sous Android 4.1.2 donc trop vieux car il faut minimum du 4.3.x. Tous les autres appareils à la maison sont quasi pareils.

Oui mais quand tu fais la recherche, vois-tu l'application sbrick dans la liste ?


Uniquement en passant par un lien donné par la team SBrick sur un réseau social. Je pense que les gens (comme moi) qui sont en-dessous de la version 4.3 d'Android ne peuvent la trouver en faisant une simple recherche.

Ce matin, je suis allé sur le support demander si une version de l'appli serait dispo pour les versions antérieures à la 4.3 et la réponse est vaguement oui sans dates précises:

The sBrick team wants to integrate support for some lower Android versions next year. But you will need an OTG cable and a special bluetooth dongle.

Avatar de l’utilisateur
shreckbull
Level 5
Level 5
 
Messages: 133
Localisation: Dijon
Âge: 33 ans

Messagepar shreckbull » Sam Déc 27, 2014 5:42 pm

Voici la version 0.0.20 :
https://drive.google.com/file/d/0Bz-WOQ ... sp=sharing

Il faut télécharger ce .apk sur le téléphone puis l'installer en ayant pris soin d'activer l'installation via des sources externes dans les paramètres de sécurité android.

Avatar de l’utilisateur
shreckbull
Level 5
Level 5
 
Messages: 133
Localisation: Dijon
Âge: 33 ans

Messagepar shreckbull » Sam Déc 27, 2014 5:48 pm

The sBrick team wants to integrate support for some lower Android versions next year. But you will need an OTG cable and a special bluetooth dongle.


Non cette réponse n'est pas vague sur le plan technique. Ils indiquent que via un cable USB OTG tu peux connecter un adaptateur bluetooth qui gère le LowEnergy.
Néanmoins, le support ne dit pas que l'appareil et la version d'android doivent pouvoir gérer le fonctionnement du port USB en mode OTG et qu'ils doivent supporter l'adaptateur bluetooth qui y sera raccordé.

Le cable OTG c'est çà :
Image


Prix, environ 3-5€ maximum.

Avatar de l’utilisateur
oracid
Level 5
Level 5
 
Messages: 170
Âge: 66 ans

Messagepar oracid » Sam Déc 27, 2014 5:55 pm

shreckbull a écrit:Voici la version 0.0.20 :
https://drive.google.com/file/d/0Bz-WOQ ... sp=sharing
Il faut télécharger ce .apk sur le téléphone puis l'installer en ayant pris soin d'activer l'installation via des sources externes dans les paramètres de sécurité android.

Oui mais, penses tu que cela va marcher avec une version Android inférieur à 4.3 ? Je ne pense pas, D'autant qu'il faut un câble OTG et un d'ongles Bluetooth...
Là, c'est la misère ....
Voici le lien vers le forum Android sur SBrick, https://social.sbrick.com/forums/topic/ ... iew/page/1

Je vais me replier vers mon ordi, mai je ne n'ai pas trouvé le lien pour télécharger l'application sur Windows 8.1

Avatar de l’utilisateur
shreckbull
Level 5
Level 5
 
Messages: 133
Localisation: Dijon
Âge: 33 ans

Messagepar shreckbull » Sam Déc 27, 2014 6:00 pm

Essayes de l'installer. Sur ma tablette, en 4.4 pour laquelle je ne trouve rien sur le playstore, l'application fonctionne mais je bloque à cause de la puce bluetooth qui n'est que v3.

Et je n'ai pas de dongle BT v4 low energy.

Avatar de l’utilisateur
YodaSoftware
Level 8
Level 8
 
Messages: 937
Localisation: POITIERS (86)
Âge: 50 ans
collectionneur

Messagepar YodaSoftware » Sam Déc 27, 2014 6:26 pm

shreckbull a écrit:Voici la version 0.0.20 :
https://drive.google.com/file/d/0Bz-WOQ ... sp=sharing

Il faut télécharger ce .apk sur le téléphone puis l'installer en ayant pris soin d'activer l'installation via des sources externes dans les paramètres de sécurité android.

ça ne change rien sur mon xPeria SP, l'application se lance bien, je peux ajouter un MOC, créer le mien, ajouter un profil de commande, ... mais pas détecter de SBrick :(
je verrais la semaine prochaine, je testerais avec la tablette de ma nièce.
Ma Collection BrickSet
Mes « I want » BrickSet

May Charlie be with us . . . Always !

Avatar de l’utilisateur
shreckbull
Level 5
Level 5
 
Messages: 133
Localisation: Dijon
Âge: 33 ans

Messagepar shreckbull » Sam Déc 27, 2014 10:37 pm


Dédé
Level 4
Level 4
 
Messages: 63

Messagepar Dédé » Sam Déc 27, 2014 10:42 pm

Salut,

Je viens de recevoir la mienne. Pour commencer elle fonctionne, mais j'ai un petit soucis, au niveau de la prise coté alimentation j'ai une "pine" qui est plus enfoncée que les autres (voir photo)
Image

Lien : http://postimg.org/image/mvzpkrga5/

Avez vous le même problème sur la votre ? J'ai eu du mal à la clipser dés le début, et j'espère ne pas l'avoir "enfoncée"

Ps: Je n'arrive pas à insérer comme il faut l'image dans le post dsl

Avatar de l’utilisateur
shreckbull
Level 5
Level 5
 
Messages: 133
Localisation: Dijon
Âge: 33 ans

Messagepar shreckbull » Sam Déc 27, 2014 11:05 pm

Tu peux facilement ouvrir et retirer le PCB, regarde mes photos plus haut.

Dédé
Level 4
Level 4
 
Messages: 63

Messagepar Dédé » Dim Déc 28, 2014 12:04 am

Ok merci, en fait j'ai une pine qui est soudée plus basse que les autres ... bon ca devrait aller merci ;)

Avatar de l’utilisateur
shreckbull
Level 5
Level 5
 
Messages: 133
Localisation: Dijon
Âge: 33 ans

Messagepar shreckbull » Dim Déc 28, 2014 2:16 am

Maj 0.0.21 sortie ...

Avatar de l’utilisateur
oracid
Level 5
Level 5
 
Messages: 170
Âge: 66 ans

Messagepar oracid » Dim Déc 28, 2014 10:00 am

Voici un lien qui vous permettra de déterminer si votre Smartphone est compatible : https://play.google.com/store/apps/deta ... git.sbrick
Approcher votre Smartphone de votre PC.
A droite du logo SBrick, cliquez sur Installer.
Dans la fenêtre qui apparaît, une liste indique que "L'application ne peut être installer sur aucun appareil".
Cliquez n'importe où sur ce message et vous verrez la référence de votre appareil qui malheureusement n'est pas compatible.
Si votre appareil est compatible alors, je suppose que vous pourrez l'installer.
Mais malheureusement, je n'ai pas pu le tester car ce n'est pas mon cas. :/


Retourner vers A propos des pièces Lego

Qui est en ligne ?

Utilisateurs parcourant actuellement ce forum : Aucun utilisateur inscrit et 3 invités

cron